Issues signing in to LinkedIn Sales Navigator

Created by Khaled Atmaz Alsibai, Modified on Mon, 9 Feb at 11:01 PM by Alsabana Sahubarali

Symptom

Sometimes, users may experience issues signing in to LinkedIn Sales Navigator or viewing information on the tiles.

Applies To

  • Outreach's users
  • LinkedIn Sales Navigator

Resolution

Try the steps below to remove the current connection with the LinkedIn Sales Navigator App, and refresh your credentials:

  1. Ensure that you are using the latest version of Google Chrome. You can follow the steps provided in this article from Google.
  2. Navigate to this Weblink.
  3. Once you are on the page, remove the entry for Outreach by clicking the Remove button next to the Outreach logo. 
  4. Clear the cookies and cache of your browser. You can find the steps to do this in another article from Google.
  5. Log out of both Outreach and LinkedIn and then try logging in again.

Cause

Refreshing the browser and removing the App connection can solve issues caused by historic browser data and cookies.


Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article