Insufficient Field Permissions errors in CRM sync

Created by Aye Myat, Modified on Mon, 9 Feb at 11:00 PM by Alsabana Sahubarali

Symptom

An Insufficient Field Permissions error appears when a CRM user is attempting to sync. The error occurs in the following scenarios

  • The integration user does not have the permissions to make any changes in your CRM via APIs.
  • The integration user does not have the permissions to change a particular field in your CRM.
  • The field being synced is not visible to the integration user via APIs.
  • You have validation rules setup in your CRM that prevent making changes to certain records in your CRM.

Applies To

  • Outreach Admins

Resolution 

Contact your CRM administrator and have them make sure that the integration user has the permissions to perform CRUD operations on all records in your CRM via APIs.

Cause

Insufficient field permissions errors occur when the CRM user used for sync does not have the permissions to make changes in your CRM via APIs.


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