Symptom
When a Outreach Admin attempts to test the SSO connection by clicking on "Test", they receive a error: {"errors":["OAuth error"]}
Applies To
What systems/software are involved?
Is the issue only specific to a certain environment?
Resolution
We will typically see this failure occur for one or more of the causes mentioned below. Importantly, the Outreach Admin and respective SSO Admin will need to verify if all steps were followed in configuring SSO.
Cause
This failure is usually caused by one or more of the following:
- The email that the user logs into Okta is not exactly identical to the login email within Outreach.
- The uploaded certificate is not the one that is generated and attached to the Outreach SSO application that was created.
- The Assertion Consumer Service (ACS) URL and the Service Provider Entity ID / Audience URI is not configured properly in Okta's configuration.
- The uploaded certificate has expired.
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